Router ID
- linkstate 프로토콜에서 각 라우터를 고유하게 식별하는 숫자. IPv4형태
- 라우터 정보 출처 확인을 위해 필요
- 거리백터의 경우 이웃 라우터에게 정보를 전파하기에 고유 식별 필요성이 적으나 링크 상태의 경우 맵의 전체 배치를 알아야 하므로 고유 router id를 기반으로 상태정보를 전파 및 추적
Router ID 필요성
-고유식별
-인접성 설정
-라우팅 정보 관리
-상태정보교환
-루프 방지
유일성
- Update 패킷에 라우터 ID를 함께 전송
- 해당 패킷에 포함된 라우터 ID와 자신의 IP를 비교
- 동일할 경우 해당 라우팅 정보를 폐기
라우터 ID 결정 방식
- 자동결정 : 루프백 인터페이스 --> 물리 인터페이스중 높은 IP주소
- 수동결정
router eigrp [AS Num]
eigrp router-id [A.B.C.D]
R2(경계 라우터)에서 RIP, EIGRP 설정을 해주고 RIP정보를 EIGRP에서 Redistribute하였다.
EIGRP,RIP광고는 172.16.0.0/16 대역과 10.0.0.0/8대역에서만 한다.
R2에서 eigrp topology 10.10.10.0/24를 보면 이에 해당하는 네트워크 대역은 2.2.2.2(R2)가 생성했음을 알 수 있다.
다만 R1에서는 라우팅 테이블 확인시 10.10.10.0/24대역을 볼 수 없는데 이는 R2와 R1 의 router id가 같아 전달받은 정보를 폐기하기 때문이다.
R1
R1 sh run
Building configuration...
Current configuration : 1657 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 172.16.12.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 200
network 172.16.12.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R1 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback10
172.16.0.0/24 is subnetted, 2 subnets
D 172.16.23.0 [90/2681856] via 172.16.12.2, 00:05:40, Serial1/0
C 172.16.12.0 is directly connected, Serial1/0
R1 sh ip eigrp topology
IP-EIGRP Topology Table for AS(200)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.16.23.0/24, 1 successors, FD is 2681856
via 172.16.12.2 (2681856/2169856), Serial1/0
P 172.16.12.0/24, 1 successors, FD is 2169856
via Connected, Serial1/0
R2
R2 sh run
Building configuration...
Current configuration : 1831 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 172.16.12.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 172.16.23.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 200
redistribute rip metric 1 1 1 1 1
network 172.16.12.0 0.0.0.255
network 172.16.23.0 0.0.0.255
no auto-summary
!
router eigrp 20
auto-summary
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R2 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback10
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.23.0 is directly connected, Serial1/1
C 172.16.12.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.10.10.0 [120/1] via 172.16.23.2, 00:00:25, Serial1/1
R2 sh ip eigrp topology
IP-EIGRP Topology Table for AS(200)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.10.10.0/24, 1 successors, FD is 2560000256
via Redistributed (2560000256/0)
P 172.16.23.0/24, 1 successors, FD is 2169856
via Connected, Serial1/1
P 172.16.12.0/24, 1 successors, FD is 2169856
via Connected, Serial1/0
IP-EIGRP Topology Table for AS(20)/ID(2.2.2.2)
R3
3 sh run
Building configuration...
Current configuration : 1732 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 3.3.3.3 255.255.255.255
!
interface Loopback20
ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 172.16.23.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router rip
version 2
network 10.0.0.0
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R3 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback10
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.23.0 is directly connected, Serial1/1
R 172.16.12.0 [120/1] via 172.16.23.1, 00:00:09, Serial1/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback20
EIGRP Metric
- 영향을 주는 요소 : Delay(지연), Bandwidth(대역폭)
- Metric = (10^7/[최소대역폭(kbps)])+[지연의 합(microsec)]/10
- 기본 메트릭의 계산식에서 대역폭이 큰 수에 영향을 미치기에 조정시 우선적 고려
QoS (Quality of Service)
- 네트워크 트래픽에 우선순위를 설정하여 특정 유형 트래픽의 대역폭을 보장하거나 제한
- dscp(패킷의 Type of Service 등) code값을 통해 전달되는 데이터의 유형을 정의 가능 --> 패킷의 분류
- EIGRP의 대역폭 설정을 통해 우선순위 설정 가능
네트워크 축약
int [interface]
ip summary-address eigrp [AS] [NI] [SM]
Null 0 경로
실제 경로가 없는 패킷을 라우터가 버리도록 설정하는 가상 인터페이스. 자동으로 생성됨.
-라우팅 루프 방지
-불필요한 트래픽을 차단
-성능을 최적화
만약 축약 네트워크및 디폴트 네트워크가 존재할 때 축약 네트워크에 의해서 없는 값이 들어오면 디폴트 네트워크로 패킷을 전송한다. 이렇게 되면 루핑이 생기게 되는데 이떄 축약 네트워크에서 없는값이면 Null 0에 의해서 패킷이 drop된다.
'네트워크 및 서버 > 네트워크' 카테고리의 다른 글
ECMP/UCMP, EIGRP 인증 (0) | 2024.10.07 |
---|---|
EIGRP Bandwidth 실습 (0) | 2024.10.01 |
EIGRP - SIA (0) | 2024.10.01 |
EIGRP 실습 (2) (0) | 2024.09.27 |
EIGRP (2) (0) | 2024.09.27 |