ECMP(Equal Cost Multi Path)
- 다중경로 라우팅
- 기본적으로 4개, IOS에 따라 16개의 로드밸런싱 가능
- 동일한 메트릭(Cost)값을 가진 경로의 로드밸런싱이 가능함.
EIGRP 설정. no auto-summary.
R1에서 R4 루프백 인터페이스로 가능 경로 확인 시 같은 코스트를 가지는 값이므로 로드밸런싱 된 것을 확인 가능.
--> ECMP
UCMP(Unequal Cost Multi Path)
- 서로 다른 메드릭 값을 가지는 경로의 로드밸런싱이 가능
- 최적 경로가 아니어도 사용 가능하며 메트릭값이 상대적으로 작은 경로에 주로 사용됨
- 설정 조건
1. Feasible successor를 통화하는 경로. --> FD > AD
2. 부하 분산을 하려는 경로의 메트릭 값이 FD * variance(1~128)값보다 작야아 함.
- 설정 방법
1. 백터 메트릭 조절(Bandwith, Delay 조정)
2. Offsetlist 활용
R2로 향하는 경로의 bandwith를 2000, R3로 향하는 경로의 bandwith를 1544로 설정
R2로 향하는 경로가 successor로 선출된것을 볼 수 있음
conf t
rotuter eigrp 1
varience 2
두개의 경로가 모두 선출된 것을 확인
bandwith 정상화 후
delay를 R2 방향 20000, R3 방향 10000으로 설정
R3방향 경로가 선출됨을 확인 가능
delay 다시 정상화.
메트릭 값이 다른 두 경로에 대하여 분산 비율을 다르게 로드밸런싱
R1
conf t
ip access-list standard [라우터 명]
permit [경로 네트워크] [와일드 마스크]
router eigrp [AS Num]
offset-list [이름] in [증가값] [interface]
variance [증가값]
R1
R1 sh run
Building configuration...
Current configuration : 1863 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.12.1 255.255.255.0
delay 2000
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.13.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
variance 2
offset-list R4 in 10000 Serial1/0
network 1.1.12.0 0.0.0.255
network 1.1.13.0 0.0.0.255
network 10.1.1.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip access-list standard R4
permit 10.1.4.0 0.0.0.255
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R1 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
C 1.1.12.0 is directly connected, Serial1/0
C 1.1.13.0 is directly connected, Serial1/1
D 1.1.24.0 [90/2425856] via 1.1.12.2, 00:08:58, Serial1/0
D 1.1.34.0 [90/2681856] via 1.1.13.1, 00:09:30, Serial1/1
[90/2937856] via 1.1.12.2, 00:09:30, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, Loopback10
D 10.1.4.0 [90/2809856] via 1.1.13.1, 00:04:03, Serial1/1
[90/2563856] via 1.1.12.2, 00:04:03, Serial1/0
R2
R2 sh run
Building configuration...
Current configuration : 1686 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.12.2 255.255.255.0
delay 2000
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.24.1 255.255.255.0
delay 1000
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
network 1.1.12.0 0.0.0.255
network 1.1.24.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R2 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
C 1.1.12.0 is directly connected, Serial1/0
D 1.1.13.0 [90/2681856] via 1.1.12.1, 00:09:27, Serial1/0
C 1.1.24.0 is directly connected, Serial1/1
D 1.1.34.0 [90/2425856] via 1.1.24.2, 00:09:34, Serial1/1
10.0.0.0/24 is subnetted, 2 subnets
D 10.1.1.0 [90/2297856] via 1.1.12.1, 00:09:27, Serial1/0
D 10.1.4.0 [90/2041856] via 1.1.24.2, 00:13:14, Serial1/1
R3
R3 sh run
Building configuration...
Current configuration : 1662 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.34.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.13.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
network 1.1.13.0 0.0.0.255
network 1.1.34.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R3 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
D 1.1.12.0 [90/2681856] via 1.1.13.2, 00:08:56, Serial1/1
C 1.1.13.0 is directly connected, Serial1/1
D 1.1.24.0 [90/2681856] via 1.1.34.1, 00:09:06, Serial1/0
C 1.1.34.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
D 10.1.1.0 [90/2297856] via 1.1.13.2, 00:08:56, Serial1/1
D 10.1.4.0 [90/2297856] via 1.1.34.1, 00:04:10, Serial1/0
R4
R4 sh run
Building configuration...
Current configuration : 1760 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 10.1.4.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.34.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.24.2 255.255.255.0
delay 2000
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
network 1.1.24.0 0.0.0.255
network 1.1.34.0 0.0.0.255
network 10.1.4.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R4 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
D 1.1.12.0 [90/2681856] via 1.1.24.1, 00:09:29, Serial1/1
D 1.1.13.0 [90/2681856] via 1.1.34.2, 00:09:29, Serial1/0
C 1.1.24.0 is directly connected, Serial1/1
C 1.1.34.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
D 10.1.1.0 [90/2809856] via 1.1.34.2, 00:09:29, Serial1/0
[90/2809856] via 1.1.24.1, 00:09:29, Serial1/1
C 10.1.4.0 is directly connected, Loopback10
EIGRP 인증을 하는 이유
- 자신과 같은 AS 번호를 가질 경우 무조건 통신을 시도
- ->악의적으로 접근하는 사용자에게 네트워크 허용 가능
EIGRP MD5 인증
conf t
key chain [Key name]
key [Key Num]
key-string [PW]
int [interface]
ip authentication key-chain eigrp [AS] [Key Name]
ip authentication mode eigrp [AS] md5
위 랩에서 R1과 R2 eigrp를 md5로 암호화 할 경우 Hello 패킷은 다음과 같다
Authentication MD5 항목이 생긴것을 볼 수 있으며 이를 통해 키와 값이 같은경우만 신뢰하고 neighbor로 등록 하는 것을 볼 수 있다.
R1
R1 sh run
Building configuration...
Current configuration : 1987 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
key chain test
key 1234
key-string 1234
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.12.1 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 test
delay 2000
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.13.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
variance 2
offset-list R4 in 10000 Serial1/0
network 1.1.12.0 0.0.0.255
network 1.1.13.0 0.0.0.255
network 10.1.1.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip access-list standard R4
permit 10.1.4.0 0.0.0.255
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R1 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
C 1.1.12.0 is directly connected, Serial1/0
C 1.1.13.0 is directly connected, Serial1/1
D 1.1.24.0 [90/2425856] via 1.1.12.2, 00:11:36, Serial1/0
D 1.1.34.0 [90/2681856] via 1.1.13.1, 00:11:36, Serial1/1
[90/2937856] via 1.1.12.2, 00:11:36, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, Loopback10
D 10.1.4.0 [90/2809856] via 1.1.13.1, 00:11:36, Serial1/1
[90/2563856] via 1.1.12.2, 00:11:36, Serial1/0
R2
R2 sh run
Building configuration...
Current configuration : 1812 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
key chain test1
key 1234
key-string 1234
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 1544
ip address 1.1.12.2 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 test1
delay 2000
serial restart-delay 0
!
interface Serial1/1
bandwidth 1544
ip address 1.1.24.1 255.255.255.0
delay 1000
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
no ip address
shutdown
duplex half
!
interface Ethernet2/1
no ip address
shutdown
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
router eigrp 1
network 1.1.12.0 0.0.0.255
network 1.1.24.0 0.0.0.255
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
R2 sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 4 subnets
C 1.1.12.0 is directly connected, Serial1/0
D 1.1.13.0 [90/2681856] via 1.1.12.1, 00:11:39, Serial1/0
C 1.1.24.0 is directly connected, Serial1/1
D 1.1.34.0 [90/2425856] via 1.1.24.2, 00:11:39, Serial1/1
10.0.0.0/24 is subnetted, 2 subnets
D 10.1.1.0 [90/2297856] via 1.1.12.1, 00:11:39, Serial1/0
D 10.1.4.0 [90/2041856] via 1.1.24.2, 00:11:39, Serial1/1
'네트워크 및 서버 > 네트워크' 카테고리의 다른 글
EIGRP 실습 (0) | 2024.10.08 |
---|---|
UCMP, EIGRP 인증 실습 (0) | 2024.10.07 |
EIGRP Bandwidth 실습 (0) | 2024.10.01 |
EIGRP(3) (0) | 2024.10.01 |
EIGRP - SIA (0) | 2024.10.01 |